ALENG博客

Godaddy空间安装WordPress错误的解决办法

最近帮朋友在Godaddy买了个空间做博客,安装的博客程序是WordPress2.8.4,但是在完成安装后,登录后台发现有一个貌似很严重的提示:“Warning: Cannot modify header information – headers already sent by (output started at …/wp-config.php:1) ”这个严重的错误重置后台登陆密码的时候无法向预定的邮箱发送重置链接。

Google了一下,发现网上提供的办法都非常多,也很愚蠢。有些需要修改php.ini文件,一些办法更需要写一个复杂的文件,我一看简直要发狂了!因为我觉得像Godaddy这样的空间上安装WP应该不是什么困难的事情,如果偶尔出现错误,也不是什么大问题。后来按照这个思路,果然找到了解决这个问题的简单而又有效的办法。

什么办法呢?原来,出现这个提示,是因为在安装WP前,一般都要修改wp-config-sample.php文件,然后重命名为“wp-config.php”,问题就出现在这里:当你修改完这个文件保存的时候,默认都是保存为utf-8格式,于是就出现了这个提示。解决的方法是,重新打开wp-config.php文件,然后保存为ANSI格式覆盖上传,一些就OK了。

网络上有些人喜欢把简单的事情搞复杂。

秀一下我朋友的博客:消夏奇葩 www.xiaoxia78.com

Categories: Godaddy, 站务日志


CN域名是怎样堕落为垃圾的? » « 质疑“3G网络已基本覆盖全国”

1 条评论

  1. Godaddy空间在国内的用户体验还不是很完美的

    ALENG 于 2010-10-3 23:52:24 回复

    GD要在新加坡建机房了,届时,估计将是一个巨大的福音。

发表评论

你的 email 地址不会被公开.

*

Copyright © 2017 ALENG博客

Theme by Anders NorenUp ↑